Google Sheets processing delayed
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Feb 09, 2021 - 00:08 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 08, 2021 - 17:38 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 08, 2021 - 14:29 EST
This incident affected: Integrations (Google Sheets Integration).