Degraded performance
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 17:02 EDT
Investigating
We are investigating several user reports of degraded application performance. Please contact support@clubhouse.io if you observe any issues.
Posted Mar 13, 2020 - 12:48 EDT
This incident affected: Web App.