Email notification processing delays
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Jun 29, 2021 - 19:29 EDT
Investigating
Outgoing email notifications are currently delayed by up to an hour.
Posted Jun 29, 2021 - 12:51 EDT
This incident affected: Integrations (Email Notifications).