Delayed Google Sheets Integration updates
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 21:38 EST
Investigating
Google Sheets Integration updates may be delayed by up to an hour.
Posted Nov 30, 2020 - 13:44 EST
This incident affected: Integrations (Google Sheets Integration).