Google sheets integration updates may be delayed by over an hour
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Dec 02, 2020 - 21:15 EST
Investigating
We are currently investigating this issue.
Posted Dec 02, 2020 - 11:49 EST
This incident affected: Integrations (Google Sheets Integration).