Delays in processing outgoing requests to update Google Sheets
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 20:33 EST
Investigating
We are currently investigating this issue.
Posted Nov 23, 2020 - 12:47 EST
This incident affected: Integrations (Google Sheets Integration).