Some Pages Temporarily Broken
Incident Report for Clubhouse
Resolved
This incident has been resolved. To get the fix, refresh your browser.
Posted Feb 19, 2020 - 17:37 EST
Identified
The Status page (https://app.clubhouse.io/status) and the Manage Organization Dashboard are currently unavailable. The team has identified a fix and is in the process of deploying it.
Posted Feb 19, 2020 - 17:26 EST
This incident affected: Web App.