Google Sheets Delayed Updates
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 20:26 EST
Monitoring
Our Google Sheets integration is under significant load and we are monitoring delays with updates.
Posted Nov 19, 2020 - 14:49 EST
This incident affected: Integrations (Google Sheets Integration).