Google Sheets integration updates may be delayed by more than an hour
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Dec 01, 2020 - 19:15 EST
Investigating
We are currently investigating performance issues with our Google Sheets integration.
Posted Dec 01, 2020 - 13:01 EST
This incident affected: Integrations (Google Sheets Integration).