Email notifications delayed
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Jun 07, 2021 - 19:32 EDT
Investigating
We are currently investigating this issue.
Posted Jun 07, 2021 - 12:30 EDT
This incident affected: Integrations (Email Notifications).