Google Sheets Processing Delays
Incident Report for Clubhouse
Resolved
This incident has been resolved.
Posted Jun 22, 2021 - 15:10 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2021 - 14:30 EDT
Investigating
We are currently investigating this issue.
Posted Jun 22, 2021 - 13:03 EDT
This incident affected: Integrations (Google Sheets Integration).